• Current Donation Goals

Archived

This topic is now archived and is closed to further replies.

scanz

"acquiring Network Address" And "cannot Renew Ip Address"

Recommended Posts

scanz   

My laptop and/or router is just being a pain. I can connect perfectly fine via an Ethernet cable, but when I try to go wireless I cannot get passed "Acquiring network address" and when I go to 'Repair', it say's it cannot "Renew IP Address".

I'm running Windows XP SP3 by the way. I've checked the TCP/IP properties and both IP and DNS are set to obtain automatically.

Any solutions?

Share this post


Link to post
Share on other sites
Codger   

Annoying isn't it? It's a Windows habit I'm afraid. Because a connection has been broken at some point, or another device on your network has, or is trying to acquire, the same IP address, it's got all confused and applied the default Windows DNS settings, which are useless to you.

Make sure no ethernet cables are connected and that wireless is turned on.

Start > Run > CMD and hit enter.

You'll be presented with a window into which you'll need to type some text.

IPCONFIG /flushdns

IPCONFIG /renew

If that doesn't work.

IPCONFIG /release

IPCONFIG /renew

If that doesn't work.

Turn off your computer, then turn off the router. Make sure no other devices are turned on that might be trying to connect to the network. Leave the router off for a minute or two, then turn it back on. Then turn on your computer, followed by any other devices or computers on your network.

Share this post


Link to post
Share on other sites

Check also your IP/DHCP settings - open the window for Network Connections (where you should have a wireless, and ethernet ones listed). Right click the Wireless one, go to Properties. Ensure you are on the 'General' tab and look in the little window below for 'TCP/IP' and click the 'Properties' icon.

Check that the settings are both set to obtain automatically (as shown here) and then click OK, then OK.

Share this post


Link to post
Share on other sites
scanz   

Grahame;

No joy I'm afraid, when I do '/flushdns' I get "Could not flush the DNS Resolver Cache: Function failed during execution".

When I try '/release' and '/renew' I get "No operation can be performed on Wireless Network Connection while it has its media disconnected".

Toby;

That was the first thing I checked and it's exactly how it should be.

Share this post


Link to post
Share on other sites
Codger   
No joy I'm afraid, when I do '/flushdns' I get "Could not flush the DNS Resolver Cache: Function failed during execution".

Okay, getting a little complicated now, but try this:

Start > Run > services.msc and hit return

After a short delay, you'll see a window with a list of services available in Windows. The one we're interested in is the DNS Client. Double-click on it and check the status.

It should be started, and the startup type should be set to Automatic. If it's not started, then make sure the drop-down type is set to Automatic and start it. If it fails at this point we might have a bigger problem.

If it's already started, stop it and restart it.

If it starts okay, go back to the CMD prompt and type IPCONFIG /flushdns - if you get a message something like 'Successfully flushed the DNS cache', you're done.

Share this post


Link to post
Share on other sites
Toby;

That was the first thing I checked and it's exactly how it should be.

Sorry, helps if I read the whole post first time...

Can you also right click on the wireless connection in network connections and check that it's enabled? Silly question I know but last time I saw "No operation can be performed on Wireless Network Connection while it has its media disconnected" it was because one of our sales guys has disabled it. Is it a laptop? do you have to do 'Fn + F5' to switch it on, off or is there a switch?

Does the wireless LED show up?

Share this post


Link to post
Share on other sites
scanz   

Grahame;

It was set to disabled, so I set it to automatic and then started it and the 'flushdns' worked, but it hasn't sorted the initial problem.

Toby;

Yeah Toby it's enabled and all on and etc.

Share this post


Link to post
Share on other sites
scanz   

Oh dear guys, sorry for wasting your time, but I've sorted it and it was something rather stupid. The network key was case sensitive... *embarrassed* - although, I suppose that isn't as bad as not having the wireless enabled eh Toby.

Share this post


Link to post
Share on other sites
Oh dear guys, sorry for wasting your time, but I've sorted it and it was something rather stupid. The network key was case sensitive... *embarrassed* - although, I suppose that isn't as bad as not having the wireless enabled eh Toby.

Indeed. Bad, but not 'that' bad. ;-)

Glad it's sorted.

Share this post


Link to post
Share on other sites